Service Disruption

Incident Report for The Coupon Bureau (Prod)

Postmortem

Incident Post-Mortem Report

Incident Summary

Incident Date: June 17, 2026
Duration / Approximate Downtime: Approximately 4 hours
Severity: P1

Incident Description

On June 17, 2026, thecouponbureau.org domain unexpectedly became unavailable due to an administrative oversight. The issue resulted in service disruptions affecting deposit and redemptions functions and access to the development and production portals.

The issue was identified shortly after alerts were received from monitoring systems and partner notifications. Service was restored once access thecouponbureau.org domain was recovered.

Timeline of Events

  • ~7:30 AM CT – Service degradation began.
  • ~ 8:00 AM CT – Automated alerts and partner notifications identified transaction processing failures.
  • ~ 8:30 AM CT - Investigation Initiated and Root Cause Identified
  • 12:00 PM CT – Service fully restored and normal transaction processing resumed.
  • Post-Restoration – Monitoring and sanity tests confirmed system stability and successful transaction processing.

Root Cause Analysis

The incident was caused by an administrative oversight related to ownership and notification management for a thecouponbureau.org domain. As a result, required renewal and maintenance notifications were not received by the appropriate personnel, leading to an unexpected service interruption.

Resolution

The affected infrastructure dependency was restored, access controls and ownership information were updated, and service functionality was verified across impacted systems. Monitoring confirmed successful recovery and return to normal operations.

Corrective Actions Taken

  • Updated administrative ownership and contact information for the affected service.
  • Reviewed and validated all notification recipients for critical infrastructure assets.
  • Implemented redundant notification paths to ensure multiple team members receive renewal and maintenance alerts.
Posted Jun 23, 2026 - 00:02 UTC

Resolved

On June 17, 2026, thecouponbureau.org domain unexpectedly became unavailable due to an administrative oversight. The issue resulted in service disruptions affecting deposit and redemptions functions and access to the development and production portals.
Posted Jun 17, 2026 - 12:30 UTC